<div dir="ltr"><blockquote style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex" class="gmail_quote"><br></blockquote><div class="gmail_extra"><blockquote style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex" class="gmail_quote"><div class="gmail_quote">2016-11-09 23:18 GMT+02:00 Danny Schmarsel <span dir="ltr"><<a target="_blank" href="mailto:danny@schmarsel.de">danny@schmarsel.de</a>></span>:<br><i><br></i><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><i><span></span>
Weird. It worked fine for me and HV6 is running well on Slackware now.<br>
Have you checked if line 83 looks like this in quicktime/configure:<br></i>
<i><br></i>
<blockquote style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex" class="gmail_quote"><i>
cd thirdparty/ffmpeg* && ./configure --disable-vaapi --enable-pthreads --enable-gpl --disable-ffplay --extra-cflags=-I$TOPDIR/$LIBF</i><wbr><i>AAD_PATH/include --extra-libs=-L$TOPDIR/$LIBFAA</i><wbr><i>D_PATH/libfaad/.libs/ --disable-ffserver --disable-ffplay  && cd ../..</i><br></blockquote><div class="gmail-m_7975272886225116803HOEnZb"><div class="gmail-m_7975272886225116803h5"><i>
-Danny<br>
_____________________________<br></i></div></div></blockquote></div><br><i>GGuy</i><br><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div><div><i>can't say for sure, but it may be that the ubuntu loader needs
 a --start-group --end-group around the static libraries.  Not all 
distros need the same loader directives.  This is just a guess.<br><br></i></div><i>The faacDecOpen external is in:<br># nm quicktime/x86_64/libquicktime.</i><wbr><i>a | grep faacDecOpen<br>0000000000000030 T faacDecOpen<br><br></i></div><i>which is referenced by the Makefile from:</i><br><div><i>g++ -o ../bin/cinelerra `cat x86_64/objs`<br></i></div><div><i>in the static library list.<br><br></i></div></blockquote><i>I attached a new patch which adds the -Wl,--start-group ... -Wl,--end-group parameters.</i><br></blockquote><br></div><div class="gmail_extra">Thanks guys.<br><br>However,<br>GG's patches and Danny's suggestion <i> sed -i '83 s/configure/configure --disable-vaapi/' quicktime/configure</i>  do not work in my case (ubuntu 32-bit).<br><br>I got a successful compilation as follows (steps 1-4):<br><br><b>Step 1</b> - how to from Nicola Ferralis<br><a href="https://sourceforge.net/p/heroines/bugs/152/#dda0">https://sourceforge.net/p/heroines/bugs/152/#dda0</a><br><br>It fixes<br><br>/usr/include/bits/mathcalls.h:326: error: conflicting types for 'lrintf'<br>common.h:313: note: previous definition of 'lrintf' was here<br>make[5]: *** [bits.lo] Error 1<br><br>-------<br><b>Step 2</b> -<br>The error:<br><i><br>/home/user/cinelerra-6/quicktime/thirdparty/ffmpeg-3.0.2/libavcodec/tiff.c:401: undefined reference to `lzma_code'<br>/home/user/cinelerra-6/quicktime/thirdparty/ffmpeg-3.0.2/libavcodec/tiff.c:402: undefined reference to `lzma_end'<br>collect2: ld returned 1 exit status<br>make[2]: *** [../bin/cinelerra] Error 1</i><br><b><br>can be fixed by adding</b> `-llzma \` to /cinelerra-6/cinelerra/Makefile <br>GG proposed this idea as a part of the patch cin6.patch<br>But other ideas of GG's patches are useless in my case<br>------<br><br><b>Step 3 -</b><br><br>The error:<br>..<br>/home/user/cinelerra-6/quicktime/thirdparty/ffmpeg-3.0.2/libavcodec/vaapi.c:128: undefined reference to `vaCreateBuffer'<br>/home/user/cinelerra-6/quicktime/thirdparty/ffmpeg-3.0.2/libavcodec/vaapi.c:137: undefined reference to `vaCreateBuffer'<br>collect2: ld returned 1 exit status<br>make[2]: *** [../bin/cinelerra] Error 1<br><br><b>can be fixed by</b> adding `-lva` to /cinelerra-6/cinelerra/Makefile<br><br>----------<br><b>Step 4 - </b><br><br>The errors during `make install`<br><br> cp: cannot stat «libmpeg3/x86_64/mpeg3dump»: No such file or directory<br> cp: cannot stat «libmpeg3/x86_64/mpeg3peek»: No such file or directory<br> cp: cannot stat «libmpeg3/x86_64/mpeg3toc»: No such file or directory<br> cp: cannot stat «libmpeg3/x86_64/mpeg3cat»: No such file or directory<br> make[1]: *** [install] Error 1<br><br>can be fixed by editing /build/Makefile.cinelerra<br>cp libmpeg3/x86_64/mpeg3dump libmpeg3/x86_64/mpeg3peek libmpeg3/x86_64/mpeg3toc libmpeg3/x86_64/mpeg3cat bin<br>-><br>cp libmpeg3/i686/mpeg3dump libmpeg3/i686/mpeg3peek libmpeg3/i686/mpeg3toc libmpeg3/i686/mpeg3cat bin<br><br>==========================<br><br>GG's patch cin6.patch  + adding `-lva` work and I can get a succesful compilation but the program after running work unstable in this case.<br>My way (steps 1-4) works well and produces the stable program.<br><br></div><div class="gmail_extra">p.s.<br><br></div><div class="gmail_extra">Effect `Motion` does not have the checkbox `Track translation`<br></div><div class="gmail_extra"><a href="http://savepic.ru/12158699.png">http://savepic.ru/12158699.png</a><br>-----------<br><br></div><blockquote style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex" class="gmail_quote"><div class="gmail_extra"><i>-Resampling effects got new interfaces with the scale changed from 
floating point to numerator/denominator style input.</i><br></div></blockquote><div class="gmail_extra"><i><br></i></div><div class="gmail_extra">Weird. Can someone make a screenshot ? I do not see any changes.<br></div></div>