<html>
  <head>
    <meta http-equiv="content-type" content="text/html; charset=utf-8">
  </head>
  <body text="#000000" bgcolor="#FFFFFF">
    Hi to all!<br>
    I have problem with cinelerra on my Gentoo.<br>
    When I run it, window looks like invisible, I can see only borders.
    Process is present in system:<br>
    <br>
    <i> $ ps aux | grep cinelerra</i><i><br>
    </i><i>rand       565  0.3  0.2 254644 23252 pts/6    Sl+  16:08  
      0:00 cinelerra</i><i><br>
    </i><i> </i><br>
    I've tried 20120707, 20140710 from ~amd64 and version from
    git://git.cinelerra-cv.org/CinelerraCV.git<br>
    <br>
    Notebook:<span class="im_log_match"><br>
      HP</span> probook 470 g2<br>
    <i><br>
        $ uname -a</i><i><br>
    </i><i> Linux DragonReborn 3.18.11-gentoo #1 SMP Mon Apr 13 17:06:53
      MSK 2015 x86_64 Intel(R) Core(TM) i7-4510U CPU @ 2.00GHz
      GenuineIntel GNU/Linux</i><i><br>
    </i><i> </i><br>
    <i> $ grep cinelerra /etc/portage/package.*</i><i><br>
    </i><i> /etc/portage/package.keywords:media-video/cinelerra ~amd64</i><i><br>
    </i><i> /etc/portage/package.use:media-video/cinelerra opengl debug
      oss</i><i><br>
    </i><i> </i><br>
    What I see when run cinelerra from terminal:<br>
    <i>$ cinelerra </i><i><br>
    </i><i> Cinelerra 2.2CV  Gentoo - 20120707</i><i><br>
    </i><i> (C) 2006 Heroine Virtual Ltd.</i><i><br>
    </i><i> (C) 2006-2011 The CinelerraCV Community</i><i><br>
    </i><i> External ffmpeg</i><i><br>
    </i><i> Compiled on Пн апр 13 13:21:57 MSK 2015</i><i><br>
    </i><i> </i><i><br>
    </i><i> Cinelerra is free software, covered by the GNU General
      Public License,</i><i><br>
    </i><i> and you are welcome to change it and/or distribute copies of
      it under</i><i><br>
    </i><i> certain conditions. There is absolutely no warranty for
      Cinelerra.</i><br>
    <br>
    A bit of GDB's magic advised by familiar programmer<br>
    <br>
    <i><font size="3"> (gdb) thread 2<br>
        [Switching to thread 2 (Thread 0x7fffe838c700 (LWP 14937))]<br>
        #0 0x00007ffff071d53f in <a class="moz-txt-link-abbreviated"
          href="mailto:pthread_cond_wait@@GLIBC_2.3.2">pthread_cond_wait@@GLIBC_2.3.2</a>
        () from /lib64/libpthread.so.0<br>
        (gdb) frame 1<br>
        #1 0x00007ffff6ab221b in Condition::lock (this=0xe2cb60,
        location=<optimized out>) at condition.C:64<br>
        64 while(value <= 0) pthread_cond_wait(&cond,
        &mutex);<br>
        (gdb) p this<br>
        $1 = (Condition * const) 0xe2cb60<br>
      </font></i><i><font size="3">(gdb) p *this<br>
        $2 = {cond = {__data = {__lock = 0, __futex = 1, __total_seq =
        1, __wakeup_seq = 0, __woken_seq = 0, __mutex = 0xe2cb90,
        __nwaiters = 2, __broadcast_seq = 0}, <br>
        __size = "\000\000\000\000\001\000\000\000\001", '\000'
        <repeats 23 times>,
        "\220\313\342\000\000\000\000\000\002\000\000\000\000\000\000",
        __align = 4294967296}, mutex = {__data = {__lock = 0, __count =
        0, <br>
        __owner = 0, __nusers = 1, __kind = 0, __spins = 0, __elision =
        0, __list = {__prev = 0x0, __next = 0x0}}, __size = '\000'
        <repeats 12 times>, "\001", '\000' <repeats 26
        times>, __align = 0}, value = 0, <br>
        init_value = 0, is_binary = 0, title = 0x6dc094
        "RemoveThread::input_lock"}</font></i><br>
    <br>
    Also from GDB: <a class="moz-txt-link-freetext" href="http://pastebin.com/M7ee0vmQ">http://pastebin.com/M7ee0vmQ</a><br>
    <br>
    There is a suspection of lock on this:<br>
    <i> <br>
      input_lock->lock("RemoveThread::run");</i><br>
  </body>
</html>