[CinCV TNG] Can't read audio from ffmpeg (encoder: Lav56.40.101)

igor_ubuntu sitelve at gmail.com
Wed Sep 20 08:24:56 CEST 2017


*2017-09-20 5:36 GMT+03:00 Ken Olum <kdo at cosmos.phy.tufts.edu
<kdo at cosmos.phy.tufts.edu>>:*
>
>
>
>
> *I recently upgraded to Ubuntu 16, which uses ffmpeg instead of avconv.
> Now cinelerracv can't read the audio from files that I write with ffmpeg in
> .mov or .mp4 formats. Is the problem in ffmpeg or cinelerra-cv?*
>

Hi Ken,
yes, that is a problem of old ffmpeg in cinelerra-cv. Einar works on
upgrading avlibs in Cinelerra-CV.
This means all encoding/decoding will be replaced with new libraries.
Testing and reporting encoding/decoding errors at the current state of
Cinelerra-CV is unimportant.
If you can/want to help, please compile  Cinelerra-*CVE*
https://git.cinelerra-cv.org/gitweb?p=einar/cinelerra.git;a=summary
The changes from there will be ported to Cinelerra-CV (CVO).

git clone git://git.cinelerra-cv.org/einar/cinelerra.git cv_einar
git pull
./autogen.sh
./configure --prefix=/opt/cin-cve --with-buildinfo=git/recompile
make
sudo make install
------------

As a workaround, try to do

ffmpeg -i bad.mp4 -vcodec copy -acodec copy bad_new.mov

I tried that with your file. It works for me (in cinelerra-cv)
http://piccy.info/view3/11591444/e569f19fc57dd7cc44802582c1c5d1d7/orig/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cinelerra-cv.org/pipermail/cinelerra/attachments/20170920/41c1dcad/attachment.html>


More information about the Cinelerra mailing list