[CinCV TNG] OGV from recordmydesktop and Cinelerra's world -> errors/crashes

Einar Rünkaru einarrunkaru at gmail.com
Fri Oct 21 21:33:30 CEST 2016



On 10/20/2016 08:23 PM, igor_ubuntu wrote:
>
>
> 2016-10-20 19:07 GMT+03:00 Einar Rünkaru <einarrunkaru at gmail.com
> <mailto:einarrunkaru at gmail.com>>:
>
>     There can i get this file? I don't see this in test_ogv.tar.bz2.
>     All my ogg samples play audio with CVE.
>     I am confused.
>

ogg in CVE and CVO can have only vorbis audio. This is shortcoming of 
course.
>
> I made two test.
>   The archive test_ogv.*tar.bz2*  has /ogv-file_for_testing.ogv/ file.
> This file is made with recordmydesktop. This file causes errors and
> flickers.
> After this test I read on the internet that recordmydesktop produces
> broken ogg-files.
>
> Ok, I did a new test.
> I took original /mjpeg/pcm.mov/ from my camera, downloaded new static
> ffmpeg 3.1.4 and reencoded (with this static ffmpeg) this my original
> mov to /theora/vorbis.ogg/ file.
> /./ffmpeg -i mjpeg_pcm.mov -vcodec libtheora -b 10000000 -acodec
> libvorbis //theora/vorbis.ogg/
>
> However, and this new /theora/vorbis.ogg/ file causes errors and flickers.
> You can download this my original /mjpeg/pcm.mov/for creating test-ogg
> file here
> https://www.datafilehost.com/d/0e8ea244

Thanks, got it. For some reason I can't convert it to usable ogg. I have 
to investigate this problem.

Flickering when moving manually is unrelated to file type. This is 
problem in playback: for some reason it displays after manual moving 
black frame which remains on screen until decoder is ready with the 
right frame. Cinelerra decodes everything and applies effect on the fly 
when playing back.

Wrote this problem to my todo-list.

Einar


More information about the Cinelerra mailing list