[CinCV TNG] Building in Gentoo; Was: Re: Cinelerra 5.1: Two bugs

Miroslav Rovis miro.rovis at croatiafidelis.hr
Tue Apr 26 10:06:48 CEST 2016

Hello again (actually I forgot to greet previously, but my respect is sincere
for the Cinelerra team ;-) )!

I read a few times over your emails (and I hope there won't be 
new to discover in the meantime so I don't lose track ;-( ...I'm pretty
slow, but thoroughly I really try to do things --if they don't show to
be too difficult for me...).

Both of your mails are here, the previous is quoted twice. It's simple
for me to respond the old way, btwn the quoted lines.
On 160425-17:54-0600, Good Guy wrote:
> I should have pointed out there may be a bunch of build prerequisites
> needed on your system.  The list needed for various distros may be
> seen one you have run the "git" step using:
> cat /<build_path>/cinelerra5/cinelerra-5.1/bld_scripts/bld_prepare.sh
> If you can provide the needed installs for gentoo,
> I will update the bld_prepare.sh script for gentoo.
Very glad if we get the list for emerge'ing and it gets included in the
bld_prepare.sh script in your git!

I'm still preparing, kind of getting to understand how I should do it
this new time, but from scratch, not a recompile like there were a few

I already went through the:
and, like I wrote in:

In my case only:

emerge -tuDN libavc1394 libiec61883

was needed. I had all the other programs from that main repo README.

And also the:

libesd (esound = 0.2.28)

from that README is not needed in my case (pure alsa here).

> Yep... this is work, but once it is done, its fun.
> gg
> On Mon, Apr 25, 2016 at 5:44 PM, Good Guy <good1.2guy at gmail.com> wrote:
> > Hi,
> >
> > These are generic build instructions for building cinelerra 5.1.
> >
> > I have not yet tried this on gentoo, so I do not know what it will do,
> > but chances are it may work or only need minor tweaks to work.
> > So with that in mind:
> >
> > 1) you need a at least 2.5GB of disk storage to operate a build.
> > 2) I recommend you build and run as root,
Actually as grsecurity admin in my grsec-hardened system.
> >   just to avoid permission issues at least for the time being.
> > 3) the "git" step has to download a bunch of stuff.  (approx 100MB)
> >    give it some time to finish.
> >
No, almost 300MB. See below.
> > Run:
> >
> > cd /<build_path>/
> > git clone --depth 1 "git://git.cinelerra-cv.org/goodguy/cinelerra.git"
> > cinelerra5
It's email, and it split it, but this command:
git clone --depth 1 \
	"git://git.cinelerra-cv.org/goodguy/cinelerra.git" cinelerra5

should not be split (if any other readers are following).

And I reached here. See further below.
> > cd cinelerra5/cinelerra-5.1
> > ./configure
> > make >& log
> >
> > This will run for a while.
> > To watch the build log, use add "&" to the make, like:
> >
> > make >& log &
> > tail -f log
> >
> > ^C when the tail -f log stops   It normally ends with:
> > make[1]: Leaving directory '/<build_path>/cinelerra5/cinelerra-5.1'
> >
> > When this completes, I use:
> >
> > grep "\*\*\*.*error" -ai log
> >
> > to see if there are obvious build errors.
> >
> > If this reports build errors, email me the log from:
> > /<build_path>/cinelerra5/cinelerra-5.1/log
> > mailto: good1.2guy at gmail.com
> > and I will see what can be done.
> >
> > If this does not report errors, then run:
> > make install >> log
> >
> > on the oft chance that it actually builds on the first try, I would
> > copy the bin directory to a a good spot, and reset the file permissions
> > to match the needed user/group etc...
> >

Unless your branch, Good Guy is very different than the main branch
(which I don't expect, but don't know, so pls do tell if the procedure
for configure/make/make install is very different than for the main git
branch!), the following may hold.

I know the below (installing all in /opt) is likely simpler, but in my
heavily hardened but rather simple and as old-unix-style as possible
system (such as no poetterware --such as systemd--, actually not even
dbus, a program that some of us in the *nix world just don't trust),
that (installing all in /opt) might mean more gradm system-learning...

And I developed for myself this out-of-portage method of install by
which I keep really good track of what I install into my system...

I used:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
	--with-x --with-buildinfo=git

Have a look at the list of files that my first, and the second install
contain. It's the same list:

(marked with the time of the first install, but the first install:
and the second instaLL:
have timestamps for files at the time of their different install.

I'd like to keep to  --prefix=/usr and  --localstatedir=/var
and such, and not opt, because with my method I can easily remove the
entire install. I verified that it worked fine on Lurker, another
program that Gentoo does not offer in Portage:
Need help creating ebuild for "lurker" (not mine, the title)

> > mkdir /opt
> > cp -a /<build_path>/cinelerra5/cinelerra-5.1/lbin /opt/cin
> > chown -R "owner:group" /opt/cin
> >
> > If it all worked, you are all setup.  Just run:
> > /opt/cin/cinelerra
> >
> > Good luck.  Let me know how it goes.
> >
> > gg

Thanks. I hope I haven't been difficult with my understanding and

BTW., there's been a little more talk at grsecurity forums:
on the issue that probably awaits me in my compile from scratch from
your git branch...

Miroslav Rovis
Zagreb, Croatia
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <http://lists.cinelerra-cv.org/pipermail/cinelerra/attachments/20160426/b9cf713c/attachment.sig>

More information about the Cinelerra mailing list