[CinCV TNG] Building in Gentoo; Was: Re: Cinelerra 5.1: Two bugs

Good Guy good1.2guy at gmail.com
Tue Apr 26 01:44:46 CEST 2016


These are generic build instructions for building cinelerra 5.1.

I have not yet tried this on gentoo, so I do not know what it will do,
but chances are it may work or only need minor tweaks to work.
So with that in mind:

1) you need a at least 2.5GB of disk storage to operate a build.
2) I recommend you build and run as root,
  just to avoid permission issues at least for the time being.
3) the "git" step has to download a bunch of stuff.  (approx 100MB)
   give it some time to finish.


cd /<build_path>/
git clone --depth 1 "git://git.cinelerra-cv.org/goodguy/cinelerra.git"
cd cinelerra5/cinelerra-5.1
make >& log

This will run for a while.
To watch the build log, use add "&" to the make, like:

make >& log &
tail -f log

^C when the tail -f log stops   It normally ends with:
make[1]: Leaving directory '/<build_path>/cinelerra5/cinelerra-5.1'

When this completes, I use:

grep "\*\*\*.*error" -ai log

to see if there are obvious build errors.

If this reports build errors, email me the log from:
mailto: good1.2guy at gmail.com
and I will see what can be done.

If this does not report errors, then run:
make install >> log

on the oft chance that it actually builds on the first try, I would
copy the bin directory to a a good spot, and reset the file permissions
to match the needed user/group etc...

mkdir /opt
cp -a /<build_path>/cinelerra5/cinelerra-5.1/lbin /opt/cin
chown -R "owner:group" /opt/cin

If it all worked, you are all setup.  Just run:

Good luck.  Let me know how it goes.


On Mon, Apr 25, 2016 at 4:57 PM, Miroslav Rovis <
miro.rovis at croatiafidelis.hr> wrote:

> On 160425-13:21-0600, Good Guy wrote:
> ...
> > It seems like there is a gentoo following out there.
> > Perhaps another sporting event in the build field.
> > Sort of like Makefile shot put.  Maybe...
> Where is that happeinng? Any links would be appreciated.
> But I'm not advanced. Not a dev. That might still be of help to me, as I
> have been trying to build Cinelerra in my Gentoo out-of-portage
> (something like in Linux From Scratch) for the last two days.
> Here are my tries and where I reached with my successful (in the sense
> that it completes faultlessly) build and install of Cinelerra that...
> doesn't start for some execstack and mprotect issues, possibly because I
> use a grsecurity-hardened kernel:
> Install Cinelerra in Gentoo (out-of-portage)
> http://www.croatiafidelis.hr/foss/gentoo/cinelerra-out-of.php
> Any advice will be appreciated.
> (I had written this other email:
> Finding One's Way to Cinelerra; Was: [CinCV Old] make error
> http://lists.cinelerra-cv.org/pipermail/cinelerra/2016q2/004673.html
> but since you mention Gentoo I thought I'd reply here instead.)
> Cheers!
> --
> Miroslav Rovis
> Zagreb, Croatia
> http://www.CroatiaFidelis.hr
> _______________________________________________
> Cinelerra mailing list
> Cinelerra at lists.cinelerra-cv.org
> http://lists.cinelerra-cv.org/cgi-bin/mailman/listinfo/cinelerra
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cinelerra-cv.org/pipermail/cinelerra/attachments/20160425/e5710d94/attachment.html>

More information about the Cinelerra mailing list