[CinCV TNG] Cinelerra not display after running

Yaroslav Shevchenko lazy.starwing at gmail.com
Wed Apr 15 15:49:00 CEST 2015


Hi to all!
I have problem with cinelerra on my Gentoo.
When I run it, window looks like invisible, I can see only borders. 
Process is present in system:

/ $ ps aux | grep cinelerra//
//rand       565  0.3  0.2 254644 23252 pts/6    Sl+  16:08 0:00 cinelerra//
///
I've tried 20120707, 20140710 from ~amd64 and version from 
git://git.cinelerra-cv.org/CinelerraCV.git

Notebook:
HP probook 470 g2
/
   $ uname -a//
//Linux DragonReborn 3.18.11-gentoo #1 SMP Mon Apr 13 17:06:53 MSK 2015 
x86_64 Intel(R) Core(TM) i7-4510U CPU @ 2.00GHz GenuineIntel GNU/Linux//
///
/ $ grep cinelerra /etc/portage/package.*//
///etc/portage/package.keywords:media-video/cinelerra ~amd64//
///etc/portage/package.use:media-video/cinelerra opengl debug oss//
///
What I see when run cinelerra from terminal:
/$ cinelerra //
//Cinelerra 2.2CV  Gentoo - 20120707//
//(C) 2006 Heroine Virtual Ltd.//
//(C) 2006-2011 The CinelerraCV Community//
//External ffmpeg//
//Compiled on Пн апр 13 13:21:57 MSK 2015//
////
//Cinelerra is free software, covered by the GNU General Public License,//
//and you are welcome to change it and/or distribute copies of it under//
//certain conditions. There is absolutely no warranty for Cinelerra./

A bit of GDB's magic advised by familiar programmer

/(gdb) thread 2
[Switching to thread 2 (Thread 0x7fffe838c700 (LWP 14937))]
#0 0x00007ffff071d53f in pthread_cond_wait@@GLIBC_2.3.2 () from 
/lib64/libpthread.so.0
(gdb) frame 1
#1 0x00007ffff6ab221b in Condition::lock (this=0xe2cb60, 
location=<optimized out>) at condition.C:64
64 while(value <= 0) pthread_cond_wait(&cond, &mutex);
(gdb) p this
$1 = (Condition * const) 0xe2cb60
//(gdb) p *this
$2 = {cond = {__data = {__lock = 0, __futex = 1, __total_seq = 1, 
__wakeup_seq = 0, __woken_seq = 0, __mutex = 0xe2cb90, __nwaiters = 2, 
__broadcast_seq = 0},
__size = "\000\000\000\000\001\000\000\000\001", '\000' <repeats 23 
times>, "\220\313\342\000\000\000\000\000\002\000\000\000\000\000\000", 
__align = 4294967296}, mutex = {__data = {__lock = 0, __count = 0,
__owner = 0, __nusers = 1, __kind = 0, __spins = 0, __elision = 0, 
__list = {__prev = 0x0, __next = 0x0}}, __size = '\000' <repeats 12 
times>, "\001", '\000' <repeats 26 times>, __align = 0}, value = 0,
init_value = 0, is_binary = 0, title = 0x6dc094 "RemoveThread::input_lock"}/

Also from GDB: http://pastebin.com/M7ee0vmQ

There is a suspection of lock on this:
/
input_lock->lock("RemoveThread::run");/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cinelerra-cv.org/pipermail/cinelerra/attachments/20150415/09f2a1df/attachment.html>


More information about the Cinelerra mailing list