[CinCV TNG] Render error - file writing

jankomEarthlink janosk at earthlink.net
Wed Apr 2 20:33:58 CEST 2014


Thanks, Einar, for your comment.

The $1 ("dollar"-"number one") comes from cinelerra cv manual, circa 
2007, section 20.9.1, Rendering to mpeg2.

I don't know enough about unix/linux, and do not know how exactly pipes 
work, so I just tried to copy things from the manual and follow 
instructions. I thought the % sign at the end of Use Pipe and the $1 in 
the shell script somehow referred to each other, as some sort of command 
line argument. Anyway, I realize that a small typing mistake in command 
line situations can cause all sorts of errors. My only contention is 
that the same thing has worked before. But maybe I made an inadvertent 
edit on it - I don't know. Your constructive help is appreciated.

Janos


On 04/02/2014 11:47 AM, Einar Rünkaru wrote:
>
> Hi.
>
> On Wed, Apr 2, 2014 at 5:21 AM, jankomEarthlink <janosk at earthlink.net 
> <mailto:janosk at earthlink.net>> wrote:
>
>     Actually, this is a version compiled by myself, and it has worked
>     before. The distro is an old Fedora-3. Initially I suspected file
>     permissions, but render worked using Quicktime for Linux File Format.
>     Here is the complete story:
>
>     Rendering setup:
>     Select a file to render to:
>     <wrote in a new filename in home directory>
>     File Format: YUV4MPEG Stream
>     Video was only selected: Render video tracks
>     Create new file at each label <is not set>
>     Render range: Project
>     Insert nothing
>
>     Video rendering setup:
>     Output Path: <wrote in a new filename in home directory, same as
>     "Select file to render to"
>     Use Pipe: <selected this option, and filename with % added is
>     entered here>
>     listing of filename above:
>     Cinelerra Error:
>     mpeg2enc -v 1 -f 8 -b 4000 -q 8 -r 16 -G 18 -n n -4 1 -2 1 -K
>     tmpgenc -D 10 -E 1
>     0 -o $1
>
> I think the command line is wrong
>
> Where did the '$1' come from?
>
> When the command line is wrong mpeg2enc gives error message and exits. 
> Cinelerra can't write anything to pipe and gives write error.
>
> Einar



More information about the Cinelerra mailing list