[CinCV] Cinelerra-cv frequently hangs for some time

Christian Jaeger chrjae at gmail.com
Mon Mar 17 15:44:06 CET 2014


Hi

I've installed cinelerra-cv from the Ubuntu ppa, on Ubuntu 13.10
(iirc, it's not my computer). Our files are originally in AVI format,
I recoded them to mpeg2 using ffmpeg, cinelerra seems to only support
the latter. This works well so far except cinelerra often blocks the
user interface and goes on computing something (it then uses 100% or
more CPU on this dual core machine) for about 30 or perhaps 60
seconds. This is with a project currently containing just 3-4 pieces
of video/audio, of a total of about 50 minutes. I'm worried that it
will be painful to use while interruptions are taking up a quarter of
our time or perhaps worse.

I've been told on IRC that this happens for some users, not for
others. I'd like to belong to the latter group, how do I get there? :)
Different versions of libraries, different input video format, are
there related bug fixes in the Git version? Do you live with the
interruptions but use a faster computer to make them shorter? (This is
a Core 2 duo 2.5 Ghz or so, without a real GPU.) It seems to be CPU,
not disk bound.

Interestingly, before going with Cinelerra, we tried to use OpenShot,
which crashes all the time when using AVI, so we tried to use the
mpeg2 files instead, which made it not crash anymore but instead also
exhibit pauses (although I think the pauses were a bit longer/more
frequent in OpenShot, but that might be just because we had many
individual clips there instead of just 3-4 big ones). So I was
thinking perhaps it's got something to do with the file format
(perhaps these files must be scanned linearly?, although Cinelerra
shows a window when opening them, saying it is building a TOC file,
thus why would that be an issue still?).

Thanks for your suggestions.

Christian.


More information about the Cinelerra mailing list